1

Topic: Uploading File Full

I think...possibly...maybe, I just might have filled my upload file a little too full. I "accidentally" uploaded a graphic about 1800x1200 onto my blog. When actually <em>in</em> the process of uploading, I received a message saying the image was too large to load. One unsuccesful upload later, my upload file was filled to overflowing. I need to take this .gif off of my upload file. How?

Re: Uploading File Full

Go to Dashboard==>Write, scroll down look for offending file. Click once to activate the menu that pops up in the Browse Uploads window. Select Delete.

Knowledge of the "secret" menu in the Upload browser is where your solution hides, methinks.

3

Re: Uploading File Full

All I see in the Dashboard==>Write panel, is this: <font color="blue">Sorry, you have used your space allocation. Please delete some files to upload more files.</font>

There is nowhere else to click. Nothing.

Re: Uploading File Full

Thanks Zane, good bug you found.

I found holes in the offending code.

First, it was giving the correct error when a file was too big, then uploading it nonetheless, dumb huh.

Second, although only certain filetypes are permitted to be uploaded they all were anyway.

In your case specifically, two files in your directory violated both rules and pointed out both holes. One file was too big, yet there. Another was a forbidden filetype, but there as well.

The browse window was behaving as it should the whole time. As far as it was concerned there were no files meeting the rule, therefore no files were displayed, and your disk space was maxed out.

I've applied a patches to both and now I can't reproduce the errors.

Let me know if all's well, now.

D. Sader

5

Re: Uploading File Full

Now I can't download anything at all.
"That file size is not allowed" compared to "File sizes must be less than 150K.
Clearly my file was 80K.

Re: Uploading File Full

Don't know what I'm doing. I was happy when it stopped uploading illegal files to the server. Didn't realize the obvious.

So, , , , enough of my twiddling with the default php.ini settings. Yawn. It's back to normal, 10MB space, 1500k image size. I was hoping I could restrict it to very small file sizes, but it sticks to defaults in the "backend" anyway.

<a href="www.flickr.com">Flickr</a> it is. Get an account.  Activate plugins in your dashboard. Turn on the widget(s). Be delighted.

One step further, download their flickr upload tool for your OS and zoom zoom.

Further, I use iPhoto(OS X) and Flickr has a plugin that makes uploading not even feel like uploading. Wowzers. cool